HTML 5 E CSS 3

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

JAVASCRIPT

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

TAMPLATES

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Pages

quarta-feira, 29 de junho de 2016

Programa que utilize uma sub-rotina de Função ou Procedimento para calcular a série de Fibonacci de N termos

Programa que utilize uma sub-rotina para calcular a série de Fibonacci de N termos. A série de Fibonnacci é formada pela sequência: 1, 1, 2, 3, 5, 8, 13, 21, 34, ... etc. Está série caracteriza-se pela soma de um termo posterior com o seu anterior subsequente. Apresentar o resultado.
Usando Função:

algoritmo "Fibonacci"
funcao FIBO(TERMO:inteiro):inteiro
var
   ant,atual,fib,cont:inteiro
inicio
      para cont de 1 ate TERMO passo 1 faca
           se(cont = 1) entao
                   ant<-0
                   atual<-1
                   fib<-atual
           senao
                fib<-ant+atual
                ant<-atual
                atual<-fib
           fimse
      fimpara
     retorne fib
fimfuncao
var
   num:inteiro
inicio
      escreva("Informe um número para calcular o fibonacci: ")
      leia(num)
      escreva("O Fibonacci eh: ",FIBO(num))
fimalgoritmo


Usando Procedimento:

algoritmo "fibonacci"
procedimento FIBO(TERMO:inteiro)
var
   ant,atual,fib,cont:inteiro
inicio
      para cont de 1 ate TERMO passo 1 faca
           se(cont = 1) entao
                   ant<-0
                   atual<-1
                   fib<-atual
           senao
                fib<-ant+atual
                ant<-atual
                atual<-fib
           fimse
      fimpara
      escreva("O Fibonacci eh: ",fib)
fimprocedimento
var
   num:inteiro
inicio
      escreva("Informe um número para calcular o fibonacci: ")
      leia(num)
      FIBO(num)

fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

terça-feira, 28 de junho de 2016

Ordenar um vetor em ordem crescente em Algoritmo.

Vai preencher um vetor de 10 posições com valores aleatórios e ordenar em ordem crescentes.

algoritmo "08"
var
   vet:vetor[1..10] de inteiro
   cont,cont1,aux:inteiro
inicio
      para cont de 1 ate 10 passo 1 faca
           escreva("Informe um número: ")
           leia(vet[cont])
      fimpara
      para cont de 1 ate 10 passo 1 faca
           para cont1 de 1 ate 9 passo 1 faca
              se (vet[cont1] > vet[cont1+1])entao
                 aux<-vet[cont1]
                 vet[cont1]<-vet[cont1+1]
                 vet[cont1+1]<-aux
              fimse
           fimpara
      fimpara
      
      para cont de 1 ate 10 passo 1 faca
           escreval(cont,": ",vet[cont])
      fimpara
fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Programas básico usando Vetor em algoritmo.

Vai receber 03 números dentro de um vetor e realizar a soma deles.

algoritmo "somaVetor"
var
  vet:vetor[1..3] de inteiro
  cont,soma:inteiro
inicio
      soma<-0
      para cont de 1 ate 3 passo 1 faca
           escreval("Informe um número")
           leia(vet[cont])
           soma<-soma+vet[cont]
      fimpara
      escreval("A soma dos numeros eh:",soma)
fimalgoritmo

Vai receber 10 números e verificar quantos números são pares e quantos impares.

algoritmo "parImparVetores"
var
    vet:vetor[1..10]de inteiro
    cont,par,impar:inteiro
inicio
     par<-0
     impar<-0
     para cont de 1 ate 10 passo 1 faca
           escreval("Informe um número")
           leia(vet[cont])
           se(vet[cont]mod 2 = 0)entao
               par<-par+1
           senao
               impar<-impar+1
           fimse
     fimpara
     escreva("Par: ",par)
     escreval("Impar:",impar)

fimalgoritmo

Vai receber dois números e fazer a soma e armazenar num vetor

algoritmo "soma"
var
   vet1,vet2,vet3:vetor[1..5] de inteiro
   cont:inteiro
inicio
    para cont de 1 ate 5 passo 1 faca
         escreva("Informe o primeiro número")
         leia(vet1[cont])
         escreva("informe o segundo número")
         leia(vet2[cont])
         vet3[cont]<-vet1[cont]+vet2[cont]
    fimpara
    para cont de 1 ate 5 passo 1 faca
         escreval(cont," posição a soma eh: ",vet3[cont])
    fimpara

fimalgoritmo


Vai receber 03 números e fazer a multiplicação do seu valor pela quantidade da posição do vetor lembrando que vai começar a contar o vetor a partir 1.
algoritmo "multiplicacaoVetor"
var
    vet,vet1:vetor[1..3] de inteiro
    cont,cont1,soma:inteiro
inicio

     para cont de 1 ate 3 passo 1 faca

          escreval(cont, ":Informe um número: ")
          leia(vet[cont])
          soma<-1
          para cont1 de 1 ate cont passo 1 faca
               soma<- soma*vet[cont]
          fimpara
          vet1[cont]<-soma
     fimpara
     
     para cont de 1 ate 3 passo 1 faca
          escreval(cont," : ",vet1[cont])
     fimpara

fimalgoritmo

Vai preencher um vetor de 05 posições e exibir em ordem inversa.

algoritmo "inversaVetor"
var
   vet,vet1:vetor[1..5] de inteiro
   cont,cont1:inteiro
inicio
      cont1<-1
      para cont de 1 ate 5 passo 1 faca
           escreva(cont,": Informe um número: ")
           leia(vet[cont])
      fimpara
      para cont de 5 ate 1 passo -1 faca
              vet1[cont1]<-vet[cont]
             cont1<-cont1+1
      fimpara
       para cont de 1 ate 5 passo 1 faca
           escreval(cont," : ",vet1[cont])
      fimpara

fimalgoritmo

Vai pedir para preencher um vetor de 05 posições e calcular o seus FIBONACCI.

algoritmo "FIBONACCI"
var
     vet,vet1:vetor[1..5] de inteiro
     cont,cont1,fibo,ant,atual:inteiro
inicio
      para cont de 1 ate 5 passo 1 faca
           escreval(cont,": informe um número: ")
           leia(vet[cont])
           para cont1 de 1 ate vet[cont] passo 1 faca
                se(cont1 = 1)entao
                     fibo<-1
                     ant<-0
                     atual<-fibo
                senao
                    fibo<-ant+atual
                    ant<-atual
                    atual<-fibo
                fimse
           fimpara
           vet1[cont]<-fibo
      fimpara
      para cont de 1 ate 5 passo 1 faca
           escreval("Posição:", cont," o FIBONACCI: ",vet1[cont])
      fimpara

fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Calcular o fibonacci em Algoritmo.

Vai receber um valor e fazer o calculo do fibonacci.

algoritmo "fibonacci"
var
   n,cont,fib,ant,atual:inteiro
inicio
      cont <-1
      escreva("Informe um numero")
      leia(n)
      repita
            se(cont = 1) entao
                fib<-1
                ant<-0
                atual<-1
            senao
                fib<- ant + atual
                ant<-atual
                atual<-fib
            fimse
             escreval(cont,": fibonacci eh: ",fib)
            cont<-cont+1
      ate cont>n
fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Calcular o Fatorial em algoritmo.

Vai receber um numero e vai realizar o calculo do Fatorial.

algoritmo "fatorial"
var
      cont,n,fat:inteiro
inicio
       fat<-1
      escreva("Informe um numero para calcular o fatorial")
      leia(n)
      para cont de 1 ate n passo 1 faca
           fat<-fat*cont
      fimpara
      escreva(fat)
fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com.

Programas básicos em Algoritmo Parte 5.

Vai receber um numero e vai pedir se vai querer informar mais números no fim mostrar a soma e a media.

algoritmo "somaMedia"
var
   sair,cont,soma,n:inteiro
inicio
      cont<-0
      soma<-0
      repita
            escreva("Informe um numero:")
            leia(n)
            soma<-soma+n
            cont<-cont+1
            escreva("deseja continuar 1-sim 0-nao")
            leia(sair)
            limpatela
      ate sair = 0
      escreval("A soma eh: ",soma)
      escreva("A media eh: ",soma/cont)
fimalgoritmo

Vai receber dois números e verificar se pode ser feita a divisão caso não poder informar outro número.

algoritmo "divisao"
var
   n1,n2,cont:inteiro

inicio
      cont<-0
      escreva("Informe dois numeros: ")
      leia(n1,n2)
      se (n2 <> 0)entao
          repita
             n1<- n1-n2
             cont<-cont+1
          ate n1 < n2
          escreva(" a divisao eh : ",cont)
      senao
           escreva("Não existe divisão por zero")
      fimse

fimalgoritmo

Vai pedir para informar a base e o expoente e calcular a exponenciação e depois se o usuário deseja realizar um novo calculo.

algoritmo "exponenciação"
var
  b,ex,sair,cont,expot:inteiro
inicio
      repita
            escreva("informe a base e o expoente")
            leia(b,ex)
            cont<-0
            expot<-1
            repita
                  expot<-expot*b
                  cont<-cont+1
            ate cont=ex
            escreval("A expotenciação eh: ",expot)

            escreva("deseja continuar 1-sim 0-não")
            leia(sair)
             limpatela
      ate sair=0
fimalgoritmo 


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com.

Programas básicos em Algoritmo Parte 4

Vai somar os 100 primeiros números usando laços de repetição.

algoritmo "soma"
var
 n,cont:inteiro
inicio
      n<-0
      cont<-0
      enquanto n<=100 faca
           cont<-cont+n
           n<-n+1
      fimenquanto
      escreva("A soma eh: ",cont)
fimalgoritmo

Vai somar todos os números pares de 1 a 500.

algoritmo "somaPares"
var
   n,cont:inteiro
inicio
      n<-1
      cont<-0
    enquanto n<=500 faca
        se(n mod 2 =0)entao
           escreval("",n)
           cont<-cont+n
        fimse
       n<-n+1
    fimenquanto
    escreva("A soma dos numeros eh: ",cont)

fimalgoritmo

Vai mostrar todos os números impares de 0 a 200.

algoritmo "numerosImpares"
var
    n:inteiro
inicio
   n<-1
   enquanto n<=200 faca
       se(n mod 2 <> 0)entao
            escreval(n)
       fimse
       n<-n+1
   fimenquanto

fimalgoritmo

Vai apresentar as potencias de base 3 variando de 0 a 15
algoritmo "potencias"
var
  x,y,poten:inteiro
inicio
   x<-0
   y<-1
   poten<-1
   enquanto x<=15 faca
       enquanto y<=x faca
            poten<-poten*3
            y<-y+1
       fimenquanto
       escreval("potencia de base: ",x," eh: ",poten)
       x<-x+1
   fimenquanto

fimalgoritmo

Vai receber a base e o expoente e fazer o seu calculo da Potencia.
algoritmo "calcularPotencia"
var
     b,ex,x,y,poten:inteiro
inicio
      poten<-1
      x<-0
      y<-0
      escreva("Informe uma base: ")
      leia(b)
      escreva("Informe um expoente: ")
      leia(ex)
      enquanto x<=ex faca
          enquanto y<x faca
             poten<-poten * b
             y<-y+1
          fimenquanto
          escreval("a Potencia do expoente: ",x," eh:",poten)
          x<-x+1
      fimenquanto

fimalgoritmo

Vai receber valor positivo e saia até receber um valor negativo e apresentar o maior e o menor número digitado.

algoritmo "maiorMenor"
var
      n,menor,maior:inteiro
inicio
      n<-0
      menor<-0
      maior<-0
      enquanto n>=0 faca
          escreval("Digite um número: ")
          leia(n)
          se(n>maior)entao
             maior<-n
          fimse
          se(n<menor)entao
             menor<-n
          fimse
      fimenquanto
      escreva("O maior número eh: ",maior)
      escreva("O menor numero eh: ",menor)

fimalgoritmo

Vai achar a media de 10 números digitados.

algoritmo "media"
var
   n,cont:real
   x:inteiro
inicio
      x<-1
      cont<-0
      enquanto x<=3 faca
           escreva("Digite um número ")
           leia(n)
           cont<-cont+n
           x<-x+1
      fimenquanto
      escreva("A media eh: ",cont/3)

fimalgoritmo


Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Programas básicos em Algoritmo Parte 3

O usuário vai informar o salario e conforme o valor vai ser o reajuste.

algoritmo "01"
var
   salario:real
inicio
   escreva("Informe o seu salario")
   leia(salario)
   se(salario < 500)entao
      escreva("O seu salario vai se de: ",salario+(salario*0.15))
   fimse
   se(salario >=500)ou(salario <=1000)entao
      escreva("O seu salario vai se de: ", salario+(salario*0.10))
   senao
      escreva("O seu salario vai se de: ",salario+(salario*0.05))
   fimse
fimalgoritmo

Informar 02 números e depois um terceiro e verificar se está na faixa numérica dos números

algoritmo "faixaNumerica"
var
   n1,n2,n3,aux:inteiro
inicio
   escreva("Informe o primeiro número")
   leia(n1)
   escreva("Informe o segundo número")
   leia(n2)
   se(n1<n2)entao
      escreva("Informe o terceiro numero: ")
      leia(n3)
      se(n1<n3)e(n2>n3)entao
           escreva("O terceiro numero esta dentro da faixa")
      senao
           escreva("O terceiro numero não esta dentro da faixa")
      fimse
   senao
        aux<-n1
        n1<-n2
        n2<-aux
        escreva("Informe o terceiro numero")
        leia(n3)
        se(n1<n3)e(n2>n3)entao
             escreva("O terceiro numero esta dentro da faixa")
        senao
             escreva("O terceiro numero não esta dentro da faixa")
        fimse
   fimse

fimalgoritmo

Informar 04 números e verificar se são divisíveis por 2 e 3.

algoritmo "divisiveis"
var
     n1,n2,n3,n4:inteiro
inicio
      escreva("Informe o primeiro numero")
      leia(n1)
      escreva("Informe o segundo numero")
      leia(n2)
      escreva("Informe o terceiro numero")
      leia(n3)
      escreva("Informe o quarto numero")
      leia(n4)
      se(n1 mod 2 = 0) e (n1 mod 3 = 0)entao
            escreval("O 1º numero e divisivel",n1)
      fimse
      se(n2 mod 2 = 0) e (n2 mod 3 = 0)entao
            escreval("O 2º numero e divisivel",n2)
      fimse
      se(n3 mod 2 = 0) e (n3 mod 3 = 0)entao
            escreval("O 3º numero e divisivel",n3)
      fimse
      se(n4 mod 2 = 0) e (n4 mod 3 = 0)entao
            escreval("O 4º numero e divisivel",n4)
      fimse

fimalgoritmo

Informar as 04 notas Bimestrais e verificar se o Aluno foi aprovado ou não.

algoritmo "notasAprovacao"
var
      n1,n2,n3,n4,md,ne,mf:real
inicio
      escreva("Informe a primeira nota")
      leia(n1)
      escreva("Informe a segunda nota")
      leia(n2)
      escreva("Informe a terceira nota")
      leia(n3)
      escreva("Informe a quarta nota")
      leia(n4)
      md<-(n1+n2+n3+n4)/4
      se(md>=7)entao
          escreva("O aluno foi aprovado direto com a nota",md)
      senao
           escreva("Informe a nota do exame")
           leia(ne)
           mf<-(md+ne)/2
           se(mf>=5)entao
              escreva("O aluno foi aprovado no exame com a nota",mf)
           senao
                escreva("O aluno foi reprovado no exame com a nota",mf)
           fimse
      fimse

fimalgoritmo

Programas básicos em Algoritmo Parte 2

Vai pedir para informar o nome e o sexo e dar uma saudação.

algoritmo "sexo"
var
      nome:caracter
      sexo:inteiro
inicio
      escreva("Informe o seu nome: ")
      leia(nome)
      escreva("Informe o seu sexo 1-masculino 2-femenino: ")
      leia(sexo)
      se(sexo = 1)entao
         escreva("Bem vindo senhor: ",nome)
      fimse
      se(sexo = 2)entao
         escreva("Bem vindo senhora: ",nome)
      fimse
fimalgoritmo


Informar dois números e achar a diferença do maior pelo menor

algoritmo "numero"
var
   n1,n2:inteiro
inicio
   escreva("Informe o primeiro numero")
   leia(n1)
   escreva("Informe o segundo numero")
   leia(n2)
   se(n1>n2)entao
     escreva("A diferença dos números eh: ",n1-n2)
   fimse
   se(n2>n1)entao
       escreva("A diferença dos números eh: ",n2-n1)
   fimse
fimalgoritmo

Vai pedir um número e apresentar ele positivo se for negativo deixar positivo.

algoritmo "positivo"
var
   n1:inteiro
inicio
   escreva("Informe um numero: ")
   leia(n1)
   se(n1>0)entao
      escreva("O número eh: ",n1)
   fimse
   se(n1<0)entao
      escreva("O número eh: ",n1*(-1))
   fimse
fimalgoritmo


Informa 4 números e vai verificar qual são divisíveis por 3.

algoritmo "divisiveis "
var
   n1,n2,n3,n4:inteiro
inicio
   escreva("Informe o primeiro numero: ")
   leia(n1)
   escreva("Informe o segundo numero: ")
   leia(n2)
   escreva("Informe o terceiro número: ")
   leia(n3)
   escreva("Informe o quarto número: ")
   leia(n4)
   se(n1%3=0)entao
      escreva("o primeiro número: ",n1)
   fimse
   se(n2%3=0)entao
      escreval("o segundo número: ",n2)
   fimse
   se(n3%3=0)entao
      escreval("o terceiro número: ",n3)
   fimse
   se(n4%3=0)entao
      escreval("o quarto número: ",n4)
   fimse

fimalgoritmo

Informar um número e achar se é par ou impar.

algoritmo "parImpar"
var
  n1:inteiro
inicio
   escreva("Informe um numero: ")
   leia(n1)
   se(n1%2=0)entao
      escreva("O número e Par")
   fimse
   se(n1%2<>0)entao
      escreva("O número e Impar")
   fimse

fimalgoritmo

Informar 05 números e achar qual é o maior e qual é o menor.
algoritmo "maiorMenor"
var
   n1,n2,n3,n4,n5,maior,menor:inteiro
inicio
   escreva("Informe o primeiro número: ")
   leia(n1)
   escreva("Informe o segundo número: ")
   leia(n2)
   escreva("Informe o terceiro número: ")
   leia(n3)
   escreva("Informe o quarto número: ")
   leia(n4)
   escreva("Informe o quinto número: ")
   leia(n5)
   maior<-n1
   menor<-n1
   se(n2>maior)entao
      maior<-n2
   fimse
   se(n3>maior)entao
      maior<-n3
   fimse
   se(n4>maior)entao
      maior<-n4
   fimse
   se(n5>maior)entao
      maior<-n5
   fimse
   
   se(n2<menor)entao
      menor<-n2
   fimse
   se(n3<menor)entao
      menor<-n3
   fimse
   se(n4<menor)entao
      menor<-n4
   fimse
   se(n5<menor)entao
      menor<-n5
   fimse
   escreval("O maior número eh: ",maior)
   escreva ("O menor número eh: ",menor)
fimalgoritmo

Informar 03 números e ordenar eles em ordem crescente ou decrescente conforme o desejo do usuário.
algoritmo "crescenteDecrescente "
var
   n1,n2,n3,opc:inteiro
inicio
   escreva("Informe o primeiro número")
   leia(n1)
   escreva("Informe o segundo número")
   leia(n2)
   escreva("Informe o terceiro número")
   leia(n3)
   escreva("1-crescente 2-decrescente")
   leia(opc)
   se(opc = 1)entao
       se(n2>=n1) e (n3>=n2) entao
           escreva(n1,n2,n3)
       fimse
       se(n2>=n3) e (n3>=n1)entao
           escreva(n1,n3,n2)
       fimse
       se(n3>=n1) e (n1 >=n2)entao
           escreva(n2,n1,n3)
       fimse
       se(n2>= n1) e (n1 >= n3)entao
           escreva(n3,n1,n2)
       fimse
       se(n1>= n3) e (n3 >= n2)entao
           escreva(n2,n3,n1)
       fimse
       se(n1>= n2) e (n2>= n3)entao
           escreva(n3,n2,n1)
       fimse
       se(n1= n2) e (n2= n3)entao
           escreva(n1,n2,n3)
       fimse
   fimse
   se(opc = 2)entao
         se(n2<=n1)e ( n3<=n2)entao
              escreva(n3,n2,n1)
         fimse
         se(n2<=n3) e (n3<=n1)entao
              escreva(n2,n3,n1)
         fimse
         se(n3<=n1)e( n1 <=n2)entao
              escreva(n3,n1,n2)
         fimse
         se(n2<= n1) e (n1 <= n3)entao
              escreva(n2,n1,n3)
         fimse
         se(n1<= n3) e (n3 <= n2)entao
              escreva(n1,n3,n2)
         fimse
         se(n1<= n2) e (n2<= n3)entao
              escreva(n1,n2,n3)
         fimse
         se(n1=n2)e (n2=n3)entao
              escreva(n3,n2,n1)
         fimse
   fimse
   se(opc<1)ou(opc>2)entao
        escreva("Opção inválida!")
   fimse

fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com.

Uma calculadora básica em Algoritmo.

Vai receber dois valores e perguntar qual das operações básicas matemática irá ser realizada.

algoritmo "calculadora "
var
   n1,n2:real
   opc:inteiro
inicio
    escreva("Informe o primeiro número")
    leia(n1)
    escreva("Informe o segundo número")
    leia(n2)
    escreval("Informe a operação desejada")
    escreval("1-somar 2-subtrair 3-mutliplicação 4-divisão")
    leia(opc)
    se(opc = 1)entao
       escreva("A soma dos números eh: ",n1+n2)
    fimse
    se(opc = 2)entao
       escreva("A subtração dos números eh: ",n1-n2)
    fimse
    se(opc = 3)entao
       escreva("A mutiplicação dos números eh: ",n1*n2)
    fimse
    se(opc = 4)entao
        se(n2 = 0)entao
          escreva("Não exite divisão por zero")
        fimse
        se(n2>0)entao
           escreva("A divisão dos números eh: ",n1/n2)
        fimse
    fimse
fimalgoritmo

Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

Programas básicos em algoritmos usando estruturas de decisão

Achar a media de 4 notas e ver se o aluno foi aprovado ou reprovado usando "se / fimse".

algoritmo "01"
var
   n1,n2,n3,n4,media:real
inicio

   escreva("informe o primeiro numero")
   leia(n1)
   escreva("Informe o segundo numero")
   leia(n2)
   escreva("Informe o terceiro numero")
   leia(n3)
   escreva("Informe o quarto numero")
   leia(n4)
   media<-(n1+n2+n3+n4)/4
   se(media>=7)entao
      escreva("O aluno foi aprovado")
   fimse
   se(media<7)entao
      escreva("O aluno foi reprovado")
   fimse
fimalgoritmo



Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com.

Programas básicos em Algoritmos Parte 1.

Mostre uma mensagem "ola mundo" em algoritmo.

algoritmo "01"
var
inicio
      escreva("ola mundo")
fimalgoritmo


Transformar temperatura em Cº em Fahrenheit.

algoritmo "02"
var
   tempC,tempF:real
inicio
   escreva("Informe a temperatura em graus Cº")
   leia(tempC)
   tempf<-tempC * 1.8 + 32
   escreva("\nA Temperatura em Fahrenheit eh:",tempF)

fimalgoritmo


Transformar temperatura Fahrenheit em graus Cº.

algoritmo "03"
var
   tempC,tempF:real
inicio
   escreva("Informe a Temperatura em Fahrenheit")
   leia(tempF)
   tempc<- (tempF - 32) / 1.8
   escreva("A temperatura em Cº: ",tempC)
fimalgoritmo

//°C = (°F – 32) / 1,8


Programa que vai receber o Valor da Prestação em atraso e o juros e calcular a nova prestação.

algoritmo "04"
var
   valor,taxa,prestacao:real
   tempo:inteiro
inicio
   escreva("Informe o valor da prestação")
   leia(valor)
   escreva("Informe a taxa de juros")
   leia(taxa)
   escreva("Informe o tempo em atraso em mês")
   leia(tempo)
   prestacao<- valor + (valor * (taxa/100)) * tempo
   escreva("O valor da Prestação em atraso e de: ",prestacao)

fimalgoritmo

O usuário vai digitar dois valores e troca de valores entre variáveis.

algoritmo "05"
var
   a,b,aux:inteiro
inicio
   escreva("Informe o valor para A: ")
   leia(a)
   escreva("Informe o valor para B: ")
   leia(b)
   aux<-a
   a<-b
   b<-aux
   escreva("A:",a)
   escreva("B: ",b)

fimalgoritmo

Apresentar o quadrado da diferença do primeiro pelo segundo.

algoritmo "06"
var
   n1,n2,dif:inteiro
inicio
   escreva("informe o primeiro numero")
   leia(n1)
   escreva("informe o segundo numero")
   leia(n2)
   dif<-n1-n2
   escreva("O quadrado da diferença e: ",dif * dif)

fimalgoritmo

Achar o valor em dollar.

algoritmo "07"
var
   cotDol,valReal,valorDol:real
inicio
    escreva("Informe o valor da cotação do Dollar: ")
    leia(cotDol)
    escreva("Informe a quantidade de dinheiro em Dollar: ")
    leia(valorDol)
    valReal<- cotDol * valorDol
    escreva("O valor em R$: ",valReal)

fimalgoritmo

Soma dos quadrados de 3 números
algoritmo "08"
var
   n1,n2,n3,quadrado:inteiro
inicio
   escreva("Informe o primeiro numero")
   leia(n1)
   escreva("Informe o segundo numero")
   leia(n2)
   escreva("Informe o segundo numero")
   leia(n3)
   quadrado <-(n1*n1)+(n2*n2)+(n3*n3)
   escreva("A soma dos quadrados eh: ",quadrado)

fimalgoritmo

Quadrado da soma de 3 números.

algoritmo "09"
var
   n1,n2,n3,quadrado:inteiro
inicio
   escreva("Informe o primeiro numero")
   leia(n1)
   escreva("Informe o segundo numero")
   leia(n2)
   escreva("Informe o terceiro numero")
   leia(n3)
   quadrado <- (n1+n2+n3)*(n1+n2+n3)
   escreva("O quadrado da soma dos numero eh: ",quadrado)

fimalgoritmo

Um programa que vai calcular a porcentagem dos votos de 3 candidato numa eleição.

algoritmo "10"
var
    candA,candB,candC,branco,nulo,totalEleitores:inteiro
    votosValidos:real
inicio
    escreva("Informe a quantidade de voto para o Canditado A: ")
    leia(candA)
    escreva("Informe a quantidade de voto para o Canditado B: ")
    leia(candB)
    escreva("Informe a quantidade de voto para o canditado C: ")
    leia(candC)
    escreva("Informe a quantidade de votos em brancos: ")
    leia(branco)
    escreva("Informe a quantidade de votos nulos: ")
    leia(nulo)
    totalEleitores <- candA + candB + candC + branco + nulo
    votosValidos <- (totalEleitores / 100)  *(candA + candB + candC)
    escreval("O total de Eleitores eh: ",totalEleitores)
    escreval("A Porcentual de votos validos: ",votosValidos)
    escreval("O Porcentual de votos para canditado A: ",(totalEleitores / 100)  *candA )
    escreval("O Porcentual de votos para canditado B: ",(totalEleitores / 100)  *candB )
    escreval("O Porcentual de votos para canditado C: ",(totalEleitores / 100)  *candC )
    escreval("O Porcentual de votos para canditado Branco: ",(totalEleitores / 100)  *branco )
    escreval("O Porcentual de votos para canditado Nulo: ",(totalEleitores / 100)  *nulo)

fimalgoritmo



Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com

segunda-feira, 27 de junho de 2016

Sistema de Controle de Cantina Simples em C.

O proprietário de uma cantina necessita de um sistema que o ajude a controlar a venda de seus produtos. Como teste inicial do sistema, ele deve controlar apenas as vendas de 01 - suco (garrafas 500 ml), 02 - refrigerante (lata), 03 - salgadinho frito, 04 - salgadinho assado e 05 - doce. Ao executar o sistema pela primeira vez, o usuário deverá informar o estoque de cada produto e o seu valor.
O sistema deve exibir o seguinte menu:
1-Vender
2-Consultar estoque
3-Consultar lucro
4-Repor estoque
0-Sair

Os itens do menu devem seguir as seguintes regras:
1-O cliente deve escolher qual produto irá comprar pelo código, como está no inicio do exercício. O sistema irá exibir o valor do produto e solicitará que o usuário informe a quantidade que deseja comprar. O sistema irá verificar se o estoque atual atende àquela venda e, caso atenda, mostrar o valor total da compra e baixar o estoque do produto, caso contrário, exibe a mensagem “Não há estoque disponível para atender a venda”.

2-O sistema irá mostrar cada produto, a sua quantidade em estoque, o valor total de cada produto em estoque e o valor total do estoque.

3-O sistema mostrará o quanto (em R$) foi vendido de cada produto.

4-O usuário deverá escolher qual produto irá repor informar a quantidade a ser reposta e então mostrar o estoque novo do produto. Não devem ser aceitas quantidades menores ou iguais à zero.


0-Encerra a aplicação e mostra o total de vendas efetuadas, a quantidade vendida de cada produto, o quanto ficou de cada produto no estoque, seu valor e o seu valor total em estoque e o lucro total do dia.


















































































































































































































Duvidas ou Trabalhos para fazer entre em Contato: marcofernando71@gmail.com